What are the browser/OS requirements?

Zenergyst is supported on all major browsers (Google Chrome, Mozilla Firefox, Safari, Internet Explorer). It is optimized for the most up-to-date versions, so we recommended you are always running the most current version of the browser of your choice.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.